3.7.8 内核终于可以正常使用 Bumblebee 了

过年期间把 Gentoo 的内核升级到了 3.7.6,结果发现在 module-rebuild 时候发现 nvidia 的闭源驱动无法正常编译了,提示找不到内核版本信息。

Google 一下,似乎这是 3.7.6 的通病,有人写了 patch,尝试过后依然无效,难道是 3.7.6 内核有 API/ABI 变化了?尝试多种方法无果的情况下,只能安心等。要么等 nvidia 放出新版驱动,要么等内核更新。前几天发现又有了 3.7.8 版本内核,果断升级,重新 module-rebuild。OK,一切正常了,终于可以用 optirun 玩 steam 上面的大型 3D 游戏了。

PS:nvidia 你的节操早就没了吧?去年就说会开发 Linux 版的 Optimus 驱动,等正式出来估计都是 999.99 版本驱动了吧?